Error message:
Type mismatch: 'Server.HTMLEncode.
When performing an action, you may encounter an error due to missing codes in GP or Communication Context configuration.
Potential Causes
Cause 1: Missing National Code for GP
Check the GP associated with the patient’s GP practice and ensure a National Code is present.
Steps:
Go to the Case Record of the affected patient and identify the patient’s practice.
Navigate to GP Setup.
Enter the practice name in the Practice Name field and press Search.
Select a GP and click Setup GP to check if the practice has a National Code.
If no National Code is present:
Add a National Code, or
Add an End Date to the GP.
Cause 2: Missing SpineCode in Communication Context
The affected record’s Context may not have a SpineCode.
Steps:
Go to Demographics for the affected client.
Click on Communications link.
Identify the Context of the entry causing the error.
Navigate to:
Menu, then click Master Table Maintenance.
Go to Area, General, then Table, GenTelecomContext.
Edit the affected context and check if a SpineCode exists.
If missing:
Contact NHS Digital to obtain the SpineCode.
Update the GenTelecomContext master table with the correct SpineCode.
If the issue persists
If all GPs have a National Code and all Communication Contexts have a SpineCode, please type talk to a person and the Digital Assistant will put you through to a live support agent.
