Skip to main content

Error type mismatch when trying to edit patient demographics

This article provides guidance if you are unable to edit patient demographics due to error.

C
Written by Connor Baeza

Error message:

Type mismatch: 'Server.HTMLEncode.

When performing an action, you may encounter an error due to missing codes in GP or Communication Context configuration.

Potential Causes

Cause 1: Missing National Code for GP

  • Check the GP associated with the patient’s GP practice and ensure a National Code is present.

Steps:

  1. Go to the Case Record of the affected patient and identify the patient’s practice.

  2. Navigate to GP Setup.

  3. Enter the practice name in the Practice Name field and press Search.

  4. Select a GP and click Setup GP to check if the practice has a National Code.

    • If no National Code is present:

      • Add a National Code, or

      • Add an End Date to the GP.

Cause 2: Missing SpineCode in Communication Context

  • The affected record’s Context may not have a SpineCode.

Steps:

  1. Go to Demographics for the affected client.

  2. Click on Communications link.

  3. Identify the Context of the entry causing the error.

  4. Navigate to:

    • Menu, then click Master Table Maintenance.

    • Go to Area, General, then Table, GenTelecomContext.

  5. Edit the affected context and check if a SpineCode exists.

    • If missing:

      • Contact NHS Digital to obtain the SpineCode.

      • Update the GenTelecomContext master table with the correct SpineCode.


If the issue persists

  • If all GPs have a National Code and all Communication Contexts have a SpineCode, please type talk to a person and the Digital Assistant will put you through to a live support agent.

Did this answer your question?